WHMCS - V6.6
Order
==================================
PurposeCreate an account
Account activity
Recharge product
Invoice management
Key Feature
Direct Create WHMCS account into ASTPP
ASTPP invoice merge into WHMCS invoice
Direct ASTPP account recharge in WHMCS
Direct redirect ASTPP user panel in WHMCS customer login
Step to install WHMCS Addon
Get Addons → Enterprise → WHMCS → Install
Configuration
Configuration → Settings → Whmcs
Fields
Value | Description |
WHMCS URL | Set WHMCS URL with admin path Ex:http://192.168.1.110/whmcs/admin/ |
WHMCS Username | WHMCS admin user name |
WHMCS Password | WHMCS admin password |
WHMCS Secret Key | EXZnhKsTaLaG^$qDE2AM?-333tmKWb |
WHMCS IV Key | 7&k%k#Ru7eV-_=m++57^92DhQBTfBc |
Step to install and use
After install WHMCS addon in ASTPP side add new setting menu (WHMCS)
Set WHMCS information in ASTPP side
Then go to /opt/ASTPP/web_interface/astpp/addons/Premium/whmcs/web_interface/ and copy whmcs folder file in WHMCS server in appropriate place same as whmcs folder
NOTE: Chnage the below all files from updated GIT source.
The Directory in this Way :
➢ includes
➢ hooks
astpp_invoice.php
cartcheckout.php
client_delete_astpp.php
customer_process.php
menus.php
➢ lang
➢ overrides
english.php
hebrew.php
spanish.php
➢ modules
➢ servers
AstppAccount
• AstppAccount.php
AstppRecharge
• AstppRecharge.php
➢ templates
➢ Twenty-x
clientvoipaccount.phpAfter accept order same customer create into ASTPP side
Need to set ASTPP URL in WHMCS config file here is file path WHMCS_MAIN_FOLDER/config_file.php change ASTPP server URL with your ASTPP URL.
==============<?php
//Database name of ASTPP
$dbname = 'astpp';
//LOG file location
$log_file_location = '/tmp/astpp.log';
//User name
$login_user_name = 'astpp';
//0:for enable 1:for disable LOGs
$log_flag = 0;
//Licence file name
$licence_file = "licence_key.txt";
//Licence file location check URL
//For live $whmcs_url = 'http://astpp.inextrix.com/';
//$whmcs_url = 'http://portal.inextrix.com/';
$whmcs_url = 'https://primevoip.io/client/admin/';
//ASTPP server URl
//$astpp_url = 'http://192.168.1.36:8083/';
$astpp_url = 'https://dashboard.primevoip.io/';
$encryption_key = '7&k%k#Ru7eV-_=m++57^92DhQBTfBc';
$secret_iv = 'EXZnhKsTaLaG^$qDE2AM?-333tmKWb';
?>
============
Then login into WHMCS side and create ASTPP server for connect WHMCS ASTPP server(Server name should be ASTPP)
Now Create product
Top Right → Setting → System setting → Servers
==> Now + Add New Server
==> Once you click on “Add new server” you will find below page and click on “Go To Advancemode“
==> Now you will find below page and fill up details and save
Value | Description |
---|---|
Name | Keep always “ASTPP“ |
Hostname | IP of ASTPP server |
IP address | IP of ASTPP server |
Modules | AstppAccount |
Username | WHMCS username |
Password | WHMCS password |
==> After create server, Need to create AstappAccount product at WHMCS side for create account in ASTPP and need to create AstappRecharge product at WHMCS side to recharge ASTPP account.
Top Right → Setting → System setting → Product/Services
Now “+Create a new group“
Just add product group name and save it
Now “+ Create a new product“
Products/Services
Select “other”
Whne you will select “product group” URL will be a auto validate now click on continue
Value | Description |
---|---|
Product Group | VOIP |
Module | AstppRecharge |
URL |
Product Create/Edit
1) ASTPP Account Create/Edit Product
Details
Module Setting : Set Module Name “AstppAccount” and after select below option for default set value when create new account
ASTPP Account Recharge Product
Pricing : After create product go to pricing tab and set amount with recharge in ASTPP side.
There are 3 types of payment type
1) Free
2) One Time
3) Recurring
For more balance option You need to create different top ups at the same way like in below we are adding 1 USD balance One Time , Same way you can create 10 , 20 ,30, etc price topup.
Module Setting : Set Module Name- AstppRecharge for create product for recharge
Now Navigate to the Homepage of WHMCS click top left side “+“ New Order
After create product now need to generate order for both Account Create OR Account Recharge
Value | Description |
---|---|
Client | Select account of customer |
Payment Method | Paypal / Crypto |
Promotion Code | If you have add it else you can create it |
Order Status | Active / Pending |
Product/Service | Select the product which you have created |
Domain | IP or doamin of ASTPP |
Billing Cycle | Multiple option are given so select as per your needs |
Quantity | Depend on you |
Price Override | (Only enter to manually override default product pricing) |
After Submit order need to Accept order for create same WHMCS customer into astpp side(Create same customer one time in ASTPP side)
After accept order same customer create into ASTPP side.
Troubleshooting Guide
Issue:
"Something went wrong and we couldn't process your request"
This error appears when clicking on the VOIP Account button in the WHMCS client area. Please find attached screenshot:
Cause:
This usually indicates that the required template file (voipaccount.tpl
) is not placed in the correct theme directory used by WHMCS.
Solution:
Follow the steps below to resolve the issue:
Login to WHMCS Admin Panel
Navigate to:
System Settings → General Settings
Check Active Client Theme
Under the General tab, locate the Template setting.
Take note of the selected theme (e.g.,
Twenty-X
) as shown in the screenshot below.
Copy Template File to the Correct Path
Using SSH or FTP, navigate to your WHMCS installation directory on the server.
Go to the theme folder:
/path/to/whmcs/templates/<active_theme>/
Replace
<active_theme>
with the name of the theme you found in Step 2.Copy the
voipaccount.tpl
file into this folder.
Set Proper Permissions and Ownership
Run the following commands (adjust path and user/group as needed):chown www-data:www-data /path/to/whmcs/templates/<active_theme>/voipaccount.tpl chmod 644 /path/to/whmcs/templates/<active_theme>/voipaccount.tpl
Clear WHMCS Cache (optional but recommended)
You can clear the WHMCS template cache by deleting the contents of:
/path/to/whmcs/templates_c/
(Be careful not to delete the folder itself, only its contents.)
After completing these steps:
Try clicking the VOIP Account button again in the client area. The page should now load without errors.